Outbound Calling Disrupted - Now Working

Incident Report for Follow Up Boss

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 11:24 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2023 - 20:18 EST

Investigating

Start: 7:48PM ET
End: 8:02PM ET

Our monitoring has detected a drop in outbound calls. Outbound calls attempted during the outage likely failed to connect. The cause has been identified by our 3rd party calling provider, and service appears to be restored. We will continue to monitor and update this incident page if more issues are detected.
Posted Nov 28, 2023 - 20:17 EST
This incident affected: Follow Up Boss Web Application, API, iPhone App, and Android App.