Zillow Preferred Agents receiving false missed connection notifications for Real Time Tours

Incident Report for Follow Up Boss

Monitoring

A fix has been implemented and we are monitoring the solution.
Posted Aug 26, 2026 - 14:11 EDT

Investigating

We are investigating an issue causing Zillow Preferred agents to receive missed-notification messages for Real Time Tours in error. We will share more information here as it becomes available.
Posted Aug 26, 2026 - 13:56 EDT
This incident affects: Follow Up Boss Web Application, iPhone App, and Android App.