Degraded service from third party provider affecting calling in Canada
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Feb 28, 2024 - 16:11 EST
Monitoring
A fix has been implemented by our partner carrier and we are monitoring the results.
Posted Feb 28, 2024 - 15:03 EST
Identified
A third-party carrier who provides calling services in Quebec, British Columbia, and Alberta is experiencing a service disruption. Inbound calls to Follow Up Boss numbers in these provinces may intermittently fail to connect. US-based calling is not affected.

We are working closely with our partner carriers to restore service to these regions, and we will update this incident as we learn more.
Posted Feb 28, 2024 - 14:05 EST
This incident affected: Follow Up Boss Web Application, iPhone App, and Android App.