Degraded batch email delivery for some customers

Incident Report for Follow Up Boss

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 13:31 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 10:56 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2026 - 09:47 EDT

Investigating

We are seeing errors and low success rates for some customers sending batch emails.

We are investigating the issue and will post updates here as they become available.
Posted Jul 29, 2026 - 09:13 EDT
This incident affected: Follow Up Boss Web Application.