Inbound lead email processing delayed
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 11:57 EDT
Monitoring
A fix has been implemented and any lead emails that were delayed have now been processed. We will continue to monitor.
Posted Apr 10, 2024 - 11:26 EDT
Investigating
We are seeing delays in processing inbound lead emails. We are working to identify the root cause and implement a solution. Leads are not being lost but may be delayed by up to 30 minutes before appearing in Follow Up Boss.

We will post updates here as they become available.
Posted Apr 10, 2024 - 11:15 EDT
This incident affected: Follow Up Boss Web Application, iPhone App, and Android App.