Widespread Service Disruption
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 12:56 EDT
Monitoring
The cause of the disruption appears to have been an unusually high spike in traffic that, for a few minutes, outstripped the rate at which server capacity could automatically scale. We have implemented a fix, and our monitoring indicates that the site's availability is returning to normal.
Posted Apr 15, 2024 - 12:37 EDT
Investigating
We are currently experiencing a service disruption.

We are working to identify the root cause and implement a solution.

This disruption is affecting a broad number of customers and features of Follow Up Boss.

We will post updates here as they become available.
Posted Apr 15, 2024 - 12:11 EDT
This incident affected: Follow Up Boss Web Application, API, iPhone App, and Android App.