followupboss.com support page is down
Incident Report for Follow Up Boss
Resolved
We have fixed the issue, and the support page should be working as normal now.
Posted 5 days ago. Jan 11, 2019 - 12:46 EST
Identified
Currently https://www.followupboss.com/support/ is down. We have identified the issue are are working to resolve it.
Posted 5 days ago. Jan 11, 2019 - 12:12 EST
This incident affected: Website Frontend.