Degraded service from third party provider affecting Follow Up Boss support phone number

Incident Report for Follow Up Boss

Resolved

This incident has been resolved and Follow Up Boss phone support lines are functional again.
Posted May 14, 2026 - 10:55 EDT

Identified

We've identified that an issue with the third party which provides functionality for the Follow Up Boss support phone number is causing our support phone lines to not function. In the meantime, please use our email support channel to reach us for assistance.

We will provide updates here and resolve this incident once we have confirmed the issue has been resolved by our provider.
Posted May 14, 2026 - 09:25 EDT
This incident affected: Follow Up Boss Web Application.