Inbound lead email processing delayed
Incident Report for Follow Up Boss
Resolved
We've resolved this issue for the impacted accounts.
Posted Feb 10, 2024 - 17:25 EST
Identified
We've determined that this particular issue is impacting a very small number of accounts. The vast majority of customers are not currently impacted. We will update here if that changes.
Posted Feb 10, 2024 - 17:21 EST
Investigating
We are seeing delays in processing lead emails. We are working to identify the root cause and implement a solution.

We will post updates here as they become available.
Posted Feb 10, 2024 - 17:14 EST
This incident affected: Follow Up Boss Web Application, iPhone App, and Android App.