Widespread service disruption

Incident Report for Follow Up Boss

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 19:28 EST

Investigating

We are currently experiencing an intermittent service disruption. We have identified the underlying issue and are working to put preventative solutions in place for the future. This disruption can affect a broad number of customers and features of Follow Up Boss, though we expect customer impact to be low from this point forward. Users should monitor this page for updates while we restore service as we will post updates here as they become available.
Posted Jan 28, 2026 - 17:53 EST
This incident affected: Follow Up Boss Web Application, API, iPhone App, and Android App.