Web app is down
Incident Report for Follow Up Boss
Resolved
This incident has been resolved. The Follow Up Boss app was down from approximately 7:25pm - 7:35pm ET. We apologize for the downtime.
Posted May 28, 2020 - 19:46 EDT
Investigating
We are investigating the issue.
Posted May 28, 2020 - 19:28 EDT
This incident affected: Follow Up Boss Web Application and API.