We have identified and mitigated the issue that caused some users to be unable to login or use Follow Up Boss. We expect users will be able to use Follow Up Boss normally at this time. We are monitoring the issue to ensure it is resolved and we have identified steps to prevent the issue from happening again in the future.
Posted Nov 03, 2025 - 11:33 EST
Investigating
We are currently experiencing a service disruption causing some users to be unable to login or use Follow Up Boss. We are working to identify the root cause and implement a solution. This disruption is affecting a portion of (not all) customers and features of Follow Up Boss.
Users should monitor this page for new information while we restore service as we will post updates here as they become available.
Posted Nov 03, 2025 - 11:17 EST
This incident affected: Follow Up Boss Web Application and Follow Up Boss Public Website.