First to claim leads not processed correctly
Incident Report for Follow Up Boss
Resolved
If you were affected by this problem, we have removed any duplicates in your account. For any leads which were not processed correctly due to this problem, we have now processed these where possible. These affected leads have now been offered via First to Claim and will have their action plans applied as normal once the lead is claimed. For any leads we could not process at all we have tagged those with "ftc-unprocessed", so you can easily find them and take action as needed. We will send all affected account owners an e-mail with more details about how your account was affected and any further actions you may need to take.
Posted May 20, 2020 - 17:31 EDT
Identified
If you are not using First to claim feature, you are not affected by this problem.

We detected that First to claim leads were not being processed correctly from May 19th 11:10am EDT until May 20th 06:04am EDT. This problem could result in many duplicate leads created in Follow Up Boss and agents may not be notified and action plans not ran for those leads. This problem was cause by releasing a new beta feature that had some unforeseen adverse effects.

This change have been reverted and the problem is resolved for new leads coming in.

We are currently working on identifying more details about the impact of this bug and will take all actions necessarily to rectify the problem and prevent similar issues from happening again.
Posted May 20, 2020 - 06:26 EDT
This incident affected: Follow Up Boss Web Application and API.