Mailchimp integration unavailable for some customers

Incident Report for Follow Up Boss

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 12:56 EDT

Update

We are continuing to work with Mailchimp on a fix for this issue.
Posted Mar 31, 2026 - 12:22 EDT

Identified

We have identified the cause of the Mailchimp integration becoming disconnected for some customers and we are working with Mailchimp to restore service.
Posted Mar 31, 2026 - 10:27 EDT

Investigating

We are investigating reports the Mailchimp integration is becoming disconnected for some customers. Updates will be shared here as they are available.
Posted Mar 31, 2026 - 10:13 EDT
This incident affects: Follow Up Boss Web Application.