Intermittent failures accessing Follow Up Boss

Incident Report for Follow Up Boss

Resolved

This incident has been resolved and steps have been taken to prevent future recurrence.
Posted Nov 13, 2025 - 18:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 15:29 EST

Investigating

We are currently experiencing a service disruption for users and systems accessing Follow Up Boss.

We are working to identify the root cause and implement a solution.

This disruption is affecting a broad number of customers and features of Follow Up Boss.

We will post updates here as they become available.
Posted Nov 13, 2025 - 15:11 EST
This incident affected: Follow Up Boss Web Application, API, iPhone App, and Android App.