Degraded service from third party provider affecting inbound lead processing

Incident Report for Follow Up Boss

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 09:28 EDT

Investigating

The third party which provides functionality for email processing is currently experiencing a service disruption. We are investigating the issue.

We will provide updates here and resolve this incident once we have confirmed the issue has been resolved by our provider.
Posted Apr 09, 2025 - 11:55 EDT
This incident affected: Follow Up Boss Web Application, iPhone App, and Android App.