Calls in the app may not be displayed

Incident Report for Follow Up Boss

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 27, 2026 - 19:38 EDT

Identified

We are seeing an issue related to calls in the app not being displayed for some customers.

We've identified the issue and are working on a fix.
Posted Aug 27, 2026 - 19:07 EDT
This incident affects: Follow Up Boss Web Application, API, iPhone App, and Android App.