Delays in call transcription and summarization for subset of users

Incident Report for Follow Up Boss

Resolved

This incident has been resolved.
Posted May 12, 2025 - 17:12 EDT

Monitoring

We're seeing delay times returning to normal. We will continue to monitor to ensure stability.
Posted May 12, 2025 - 16:34 EDT

Identified

We have identified an issue with a third-party vendor that is resulting in higher than average delays in generating call transcriptions. We have engaged the vendor and will continue to share updates as we learn more.
Posted May 12, 2025 - 16:12 EDT
This incident affected: Follow Up Boss Web Application.