Office 365 emails sending multiple times
Incident Report for Follow Up Boss
Resolved
We have released changes that resolve this incident. One of the side effects of Microsoft's change is that we cannot support per-person email tracking when sending emails to multiple recipients via Office 365 or Outlook connected email addresses. This is something we are looking to improve.
Posted 3 months ago. Sep 27, 2018 - 09:14 EDT
Identified
We've identified the issue with duplicate emails sending when CC'ing multiple people for our Office 365 customers. The problem is caused by a recent change on Microsoft's end. We are creating a workaround for this issue.
Posted 3 months ago. Sep 26, 2018 - 13:45 EDT
Investigating
We're investigating an issue with our connected Office 365 email accounts, where sending an email and CCing multiple people will result in each person receiving duplicate copies of the email. This issue does not affect our connected google email addresses.
Posted 3 months ago. Sep 26, 2018 - 09:39 EDT
This incident affected: Follow Up Boss App.