Inbound Lead Processing delayed for some followupboss.me emails
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 14:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2020 - 14:04 EDT
Identified
We're seeing processing delay from our third-party email provider that is causing some emails to @followupboss.me address to be delayed by 15+ minutes before appearing in Follow Up Boss. We are working with third party provider to remedy and will post updates here.
Posted Oct 20, 2020 - 12:51 EDT