Delays and errors in processing Facebook Leads
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:23 EDT
Monitoring
Facebook connections and lead processing are operating normally again and we are monitoring for any continued problems.
Posted Oct 19, 2020 - 13:47 EDT
Investigating
We are investigating a drop in leads being processed from Facebook and will provide updates here.
Posted Oct 19, 2020 - 12:06 EDT
This incident affected: Follow Up Boss Web Application.