Inbound lead emails to followupboss.me lead email addresses delayed
Incident Report for Follow Up Boss
Resolved
Third party has implemented a fix and we see all backlog of lead emails have been processed and new ones are being processed as normal so this incident is resolved.
Posted Jun 01, 2021 - 12:10 EDT
Identified
Third party has identified the issue and is working on a fix.
Posted Jun 01, 2021 - 11:43 EDT
Investigating
We are seeing delays in processing lead emails for followupboss.me lead email addresses due to problems with our service provider. We are in contact with them to resolve the issue.

These emails will be processed and retried automatically once the issue is resolved.

Lead emails and emails synced for contacts via connected email addresses (Inbox Lead Processing) is unaffected and working normally.

This issue is only for customers using @followupboss.me lead email addresses for processing their leads.
Posted Jun 01, 2021 - 11:34 EDT
This incident affected: Follow Up Boss Web Application.