Issues when purchasing additional phone numbers
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 10:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 29, 2021 - 10:30 EDT
Identified
Third party provider indicates they have identified the issue and are working on a fix.
Posted Mar 29, 2021 - 10:05 EDT
Investigating
We are observing errors when customers attempt to purchase additional phone numbers for their accounts. This may prevent signing up for new trials as well. Our third party provider is investigating and we are monitoring as well.
Posted Mar 29, 2021 - 09:24 EDT
This incident affected: Follow Up Boss Web Application.