Call transcripts and summaries failing for some calls

Incident Report for Follow Up Boss

Identified

We have implemented a partial fix that has reduced the number of calls without transcripts or summaries. We are continuing to work towards a full resolution.
Posted Nov 26, 2025 - 16:29 EST

Investigating

We are investigating an issue with transcripts and summaries not appearing for some phone calls. We will provide updates here as they are available.
Posted Nov 26, 2025 - 10:23 EST
This incident affects: Follow Up Boss Web Application, iPhone App, and Android App.