Email clicks and opens tracking delay
Incident Report for Follow Up Boss
Resolved
We have found and fixed the problem, open and click tracking is working correctly again.
Posted May 12, 2019 - 08:05 EDT
Update
The processing of email clicks and opens continues to be delayed. We are actively looking into this.
Posted May 12, 2019 - 00:34 EDT
Investigating
We are currently investigating a possible outage with the system that handles our email click and open tracking.
Posted May 11, 2019 - 23:22 EDT