Inbound Lead Processing delayed for some followupboss.me emails
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 16:42 EDT
Monitoring
Third-party provider has implemented a fix and we are monitoring. At this point, it appears all delayed leads have been processed.
Posted Oct 15, 2020 - 16:34 EDT
Identified
We're seeing processing delay from our third-party email provider that is causing emails to @followupboss.me address to be delayed by 15+ minutes before appearing in Follow Up Boss. We are working with third party provider to remedy and will post updates here.
Posted Oct 15, 2020 - 16:13 EDT