Website, API and mobile app are currently unavailable
Incident Report for Follow Up Boss
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 13, 2018 - 14:29 EDT
Identified
The issue has been identified and we are working on a fix.
Posted 2 months ago. Sep 13, 2018 - 14:21 EDT
Investigating
We have identified the problem and will have the website restored in a few minutes.
Posted 2 months ago. Sep 13, 2018 - 14:19 EDT
This incident affected: Follow Up Boss App, API, and Website Frontend.