Issues with Billing Partner
Incident Report for Follow Up Boss
Resolved
Stripe has indicated this incident is resolved and we're no longer seeing errors on our end.
Posted Jul 10, 2019 - 13:56 EDT
Identified
Around 12:45pm ET we received notice that our billing provider was experiencing elevated error rates. They are aware of the issue and investigating. During this time, Follow Up Boss customers may experience issues viewing their billing information, adding or deleting users on their account, and adding or removing the calling add-on from users. You may monitor the progress of Stripe fixing this on their website https://status.stripe.com. We'll give another update when this is resolved.
Posted Jul 10, 2019 - 13:07 EDT
This incident affected: Follow Up Boss Public Website.